DDoS
Incident Report for Albion Online

The attack was mitigated. The servers were restarted as players still reported residual problems with instanced areas.

Posted 5 months ago. Aug 23, 2017 - 03:58 UTC

Resolved
This incident has been resolved.
Posted 5 months ago. Aug 23, 2017 - 03:41 UTC
Investigating
Islands, Expeditions, and Hellgates are affected by the attack.
Posted 5 months ago. Aug 23, 2017 - 01:39 UTC