Launcher Troubles
Incident Report for Albion Online
Resolved
The infrastructure changes seem to have alleviated the problem. The connection issues are resolved.
Posted 5 months ago. Sep 07, 2017 - 21:20 UTC
Monitoring
Changes to the content delivery network have been made to circumvent possible faulty connections. Monitoring results.
Posted 5 months ago. Sep 07, 2017 - 19:56 UTC
Investigating
The game launcher seems to have random issues to load the news or connect to the update site. We are investigating where this issue stems from. Starting the client through the .exe directly, bypassing the launcher, seems to be a workaround if your client is already patched.
Posted 5 months ago. Sep 07, 2017 - 19:42 UTC