Server issues
Incident Report for Albion Online
Resolved
Server is up and running again.
Posted 4 months ago. Sep 22, 2017 - 21:26 UTC
Investigating
We are aware of the server issues impacting gameplay and are investigating the cause. We will update again shortly!
Posted 4 months ago. Sep 22, 2017 - 20:56 UTC