Server Outage
Incident Report for Albion Online
Resolved
This incident has been resolved.
Posted 5 months ago. Aug 28, 2017 - 09:30 UTC
Investigating
There is an issue related to a routing failure. The game server as well as the forums are currently being affected. The team is aware in working on it now.
Posted 5 months ago. Aug 28, 2017 - 09:26 UTC